401 madness

Jun 23, 2011 at 8:22 AM

I was going around in circles for a while with 401 errors when using the WebAuthorizer or MvcAuthorizer. Long story short, I had initially setup simple auth and in the Twitter application settings on dev.twitter.com I had selected "client" application type, not "browser". If you're struggling to get the web demos to work and keep getting 401s, change your Application Type under the Edit your application settings section in dev.twitter.com.