Latest version on x64

Aug 19, 2009 at 1:32 PM

Is anyone able to use the latest library (source download) on a 64-bit platform (Windows 7 in my case) in any other web project (and specifically MVC) other than the sample one?

Seems to be an issue with Kerr.Credentials (or likely one the windows presentation assemblies it uses) ... if i take all references of that out and recompile it works fine.

The *sample* run fine but if i try using in another project - i.e. recompiling it doesn't seem to like it. Even adding the project to my existing one and referencing it directly still causes the error below.

I am getting the following - and i've added every reference available. Some searches seem to indicate platform issues but for the moment i may need t

"Could not load file or assembly 'Kerr.Credentials' or one of its dependencies. An attempt was made to load a program with an incorrect format."

steven
http://livz.org

Aug 19, 2009 at 2:30 PM

Hi,

I have the same issue in my ASP.NET MVC application and I'm looking for solution..

Aug 19, 2009 at 2:35 PM

One way to get it working in MVC is ..

1. Get the latest source.
2. Open the project.
3. Remove the references to Kerr.Credentials, the Presentation assemblies and the Windows Base.
4. Build he project and it will fail.
5. Remove everything that failed because it referenced these assemblies.
6. Build and works fine.

steven
http://livz.org 

Aug 19, 2009 at 2:45 PM

Thanks, steven!

Could you send me working LinqToTwitter assembly ?

My email: ivan.kohut at gmail.com

Aug 19, 2009 at 2:49 PM

Sure - let me package it up.

Aug 19, 2009 at 8:56 PM

Btw, I think it would be good to include ASP.NET MVC demo application into the solution..

Coordinator
Aug 20, 2009 at 1:46 AM

I just released LINQ to Twitter v2.0.1 Beta, which includes an MVC demo.  Aarnot added it to demo OAuth in MVC.  I don't work on a 64-bit machine, so I haven't built anything on a 64-bit CLR.

Joe

Coordinator
Aug 20, 2009 at 2:11 AM

Correction. My last post doesn't seem to be accurate.  I just looked in the project and noticed that there is in fact *not* an MVC demo.  I thought there was, but will have to look at it closer.  Sorry for any confusion.  There is an MvcOauthAuthorization though.

Joe

Aug 22, 2009 at 3:02 PM

I don't think the problem is with the WindowsBase or other WPF references.  The issue is that Kerr.Credentials.dll is a 32-bit native assembly.  We use this in client installed app scenarios to use the Windows Credential Store to securely keep the OAuth tokens and secrets.  However, it doesn't apply to web apps, and as you say, it unnecessarily limits the scenarios that work.  It would also kill partial trust.  

Joe, I think what we need to do here is issue two builds of L2T: one for desktop clients and another one for web sites.  I'll make a work item out of this and see what I can do.

Aug 22, 2009 at 3:03 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Sep 14, 2009 at 8:00 PM

I just ran into this same issue as well. Everything was working on my my 32-bit Vista dev computer, until I uploaded the web app to a Windows Server 2008 64-bit server.  

 

Sep 25, 2009 at 2:41 PM

I'm having the same issue... bump

 

Oct 16, 2009 at 7:16 PM

Basically, all you need to do in Visual Studio is go into the Build menu and open the Configuration Manager window. In the Active solution platform drop down, select x86, recompile, and you will then be able to run the samples on x64 machine - albiet in a 32bit context..

Dec 2, 2009 at 1:06 PM
Edited Dec 2, 2009 at 1:25 PM

Same issue - but x86 is no option for me since i try to use it inside SharePoint 2010 and this doen't like x86. Is there a 64bit (or MSIL) version of the Kerr.Credentials assembly?

Dec 7, 2009 at 4:58 AM

Try downloading the latest source and compiling it.  Kerr.Credentials is still there, but it shouldn't cause problems on 64-bit web platforms any more and you can omit copying it up to the web server altogether.

Dec 9, 2009 at 3:18 PM

it's working - i'll give you 5 stars

Dec 10, 2009 at 7:46 PM

Excellent.  Thanks for letting us know it's fixed.

May 22, 2010 at 1:27 PM

Does this apply to latest source code on SVN? I'm still getting the same problem with it, tried building under "Any CPU" build configuration and tried even "x86" and still the same error.

Jun 22, 2010 at 12:34 PM
I'm also still have same problem. I'm using MVC 2 under NET 4.0. Error is thrown when we upload project to Windows Web Server R2 X64.