Trying to run ASP Demo

Mar 16, 2011 at 11:59 AM

Hello everyone,

I'm a student, and have been assigned a project (basically an ASP.NET twitter client with database backup), so I've been looking at the sample project, especially the LinqToTwitterWebFormsDemo.

The projects runs fine and displays a list of random tweets, but whenever I fill in the web.config file with my consumerkey and secret, I get the same display, still being shown the SetupTwitterConsumer panel in the DataMultiView. It's like I didn't enter anything in the web.config !

 

if (string.IsNullOrWhiteSpace(credentials.ConsumerKey) ||
string.IsNullOrWhiteSpace(credentials.ConsumerSecret))
        {

            // The user needs to set up the web.config file to include  Twitter consumer key and secret.<-- I did that !
            PrivateDataMultiView.SetActiveView(SetupTwitterConsumer);
        }

Somehow this "if" statement succeeds when it should not.

Now, I would be more than happy to be able to make some debugging, but neither Console.Write or Debug.Write display anything in VS. (yes, I only know those two...)

I'm pretty sure this is something stupid that I am missing. I'll probably even be so ashamed once someone tells me how trivial the problem is that I will have to hide away from civilisation for a few months, but I just can't find it. Manual doesn't help either.

 

I'm using VS2010, NET Framework 4.

Sorry for the bad english, it's not my native language.

Thanks in advance.

PS : By answering this message, you will save yourself the hassle of doing it later for the two hundreds other students who were assigned the same project than me. I think it's worth it !

 


Mar 16, 2011 at 12:15 PM

I am truly sorry. It seems VS finally decided to work a few tries after this post, for whatever reason I will never be able to comprehend.

I guess it's fine then, thanks for the awesome API.

Coordinator
Mar 16, 2011 at 4:17 PM

Hi,

Glad you got it working. :)

Joe

Mar 16, 2011 at 4:29 PM

Thanks !